Issue with saving Document Options
Incident Report for ShipStation
Resolved
This incident has been resolved.
Posted May 07, 2020 - 11:21 CDT
Investigating
We are currently investigating a resolution for an issue related to saving settings for document options. We apologize for the inconvenience and will update as we have more information.
Posted May 07, 2020 - 10:46 CDT
This incident affected: ShipStation.