Stamps Outage
Incident Report for ShipStation
Resolved
This incident has been resolved.
Posted Nov 30, 2020 - 11:25 CST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Nov 30, 2020 - 10:53 CST
Identified
We are currently receiving multiple reports of label creation failing. We have reached out to Stamps.com and they are aware of the issue and working to resolve it as soon as possible. Please check back for updates regarding this issue.
Posted Nov 30, 2020 - 10:13 CST
This incident affected: Carriers (Stamps.com).