Issues with Stamps.com services

Incident Report for ShipStation

Resolved

This incident has been resolved.
Posted Apr 24, 2020 - 13:56 CDT

Investigating

We are currently investigating an issue effecting multiple users when attempting to utilize Stamps.com services. We will provide updates as they are available and apologize for any inconvenience.
Posted Apr 24, 2020 - 12:50 CDT
This incident affected: Carriers (Stamps.com).