Intermittent issues preventing login
Incident Report for ShipStation
Resolved
We have resolved the issue that was preventing users from logging in.
Posted 7 months ago. Feb 01, 2019 - 11:51 CST
Investigating
We are currently investigating an issue which is preventing some users from logging into the software.
Posted 7 months ago. Feb 01, 2019 - 11:07 CST
This incident affected: ShipStation.