USPS Errors

Incident Report for ShipStation

Resolved

This incident has been resolved.
Posted Mar 11, 2025 - 11:32 CDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 11, 2025 - 11:11 CDT

Identified

ShipStation Engineers are aware of the technical issues impacting USPS Services. We are actively working to resolve this issue and will provide updates as they become available to us.

Thank you for your patience!
Posted Mar 11, 2025 - 10:50 CDT
This incident affected: Carriers (Stamps.com).