UPS Label Creation Error
Incident Report for ShipStation
Resolved
This incident has been resolved.
Posted Mar 29, 2021 - 11:15 CDT
Identified
We have identified an issue where customers are seeing label creation errors with orders coming from Amazon. We are currently working on getting this resolved. This will cause issues with creating labels with carriers like UPS.

As a alternative, you can edit phone numbers to only included the standard 10-digit format to create a label that is seeing the issue and displaying the error message “ The ship to phone number must not exceed 15 numeric digits in length”
Posted Mar 29, 2021 - 08:32 CDT
This incident affected: Marketplaces (Amazon US) and Carriers (UPS).