ShipStation Connect Issues

Incident Report for ShipStation

Resolved

This incident has been resolved.
Posted Sep 05, 2023 - 19:04 CDT

Investigating

ShipStation is currently experiencing performance-related issues that may be affecting your ShipStation connect and printers showing in the account.

We are aware of the impact this has on you, and we are working to identify the issue! We will provide frequent updates on our progress. Thank you for your continued patience, and check back soon!
Posted Sep 05, 2023 - 16:20 CDT
This incident affected: ShipStation.