Latency Detected
Incident Report for ShipStation
Resolved
Thank you for your patience while we worked to resolve the latency and imaging issues.
Posted Dec 10, 2021 - 09:16 CST
Investigating
We are receiving reports that some users are experiencing issues with logos & product images in-app and on packing slips.
We have also received reports of general latency.
We are currently investigating this and will provide updates as they become available.

Thank you for your patience!
Posted Dec 10, 2021 - 08:26 CST
This incident affected: ShipStation.