Amazon Performance Issues

Incident Report for ShipStation

Resolved

Amazon's AWS performance issue has been resolved and store connectivity functions should be fully operational for ShipStation merchants.
Posted May 09, 2026 - 11:27 CDT

Monitoring

We are currently monitoring an Amazon Web Services (AWS) outage that may be affecting store connectivity for ShipStation merchants. Our team is monitoring the situation closely and will provide updates as new information becomes available.
Posted May 07, 2026 - 23:03 CDT
This incident affected: Marketplaces (Amazon US).