Issues Creating Labels using Canada Post by ShipStation

Incident Report for ShipStation

Resolved

This incident has been resolved.
Posted Apr 14, 2026 - 15:51 CDT

Investigating

We are currently investigating an issue preventing some users from generating Canada Post by ShipStation labels. Our team is working to resolve this as quickly as possible.
Posted Apr 08, 2026 - 14:54 CDT
This incident affected: ShipStation.