Rithium (formerly Channel Advisor) Outage Impacting All Stores

Incident Report for ShipStation

Resolved

This incident has been resolved.
Posted Nov 24, 2025 - 11:48 CST

Monitoring

ShipStation is aware of the technical issues impacting the Rithium (formerly Channel Advisor) marketplace integration. We are actively monitoring the status of these issues and will provide updates as they become available.

Thank you for your patience!

You can also check the status at the marketplace's status page, https://status.channeladvisor.com/
Posted Nov 20, 2025 - 19:22 CST
This incident affected: Marketplaces (ChannelAdvisor).