Stamps.com - Unable to Get Rate or Create Label
Incident Report for ShipStation
Resolved
This incident has been resolved.
Posted 21 days ago. Aug 26, 2019 - 15:30 CDT
Monitoring
The issue has subsided, and we are continuing to monitor performance
Posted 21 days ago. Aug 26, 2019 - 14:42 CDT
Investigating
We are investigating an issue wherein the Stamps.com postage provider is experiencing high response times on Getting Rates and Creating Labels. Will update as the situation warrants.
Posted 21 days ago. Aug 26, 2019 - 13:52 CDT
This incident affected: Carrier Integrations.