DHL Express

Incident Report for ShipStation

Resolved

This incident has been resolved.
Posted Mar 13, 2023 - 11:00 CDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 13, 2023 - 09:24 CDT

Identified

The issue has been identified and a fix is being implemented.
Posted Mar 13, 2023 - 08:17 CDT

Investigating

ShipStation is currently experiencing issues with DHL Express services when creating labels. We are aware of the impact this has on you, and we are working to identify the issue!
Posted Mar 13, 2023 - 05:05 CDT
This incident affected: Carriers (DHL Express).