Issues with FedEx International Services

Incident Report for ShipStation

Resolved

This incident has been resolved.
Posted Apr 28, 2020 - 15:26 CDT

Investigating

We are currently investigating an issue with label creation for FedEx International Services. We are in contact with FedEx who are currently investigating the matter. We will provide updates as they are available and apologize for any inconvenience. Thank you for your patience as we work to resolve.
Posted Apr 28, 2020 - 09:27 CDT
This incident affected: Carriers (FedEx).