Stamps.com authentication issue

Incident Report for ShipStation

Resolved

This incident has been resolved.
Posted Oct 20, 2020 - 18:10 CDT

Investigating

We are currently investigating an issue that is displaying that 'Authentication Failed' or “Your Stamps username and password are invalid”. More updates as soon as they are available.
Posted Oct 20, 2020 - 17:59 CDT
This incident affected: Carriers (Stamps.com).