Log-in Issues
Incident Report for ShipStation
Resolved
This incident has been resolved. Thank you for your patience!
Posted Nov 07, 2022 - 13:29 CST
Investigating
We are currently investigating an issue with merchants logging in to ShipStation. We apologize for this inconvenience and will update our status page as we know more.
Posted Nov 07, 2022 - 12:36 CST
This incident affected: ShipStation.