ShipStation

Incident Report for ShipStation

Resolved

This incident has been resolved
Posted Apr 21, 2026 - 13:36 CDT

Update

We are continuing to work on a fix for this issue.
Posted Apr 21, 2026 - 10:28 CDT

Identified

ShipStation is aware of latency and address validation issues on our platform. We are actively working to resolve this issue and will provide updates as they become available. Thank you for your patience.
Posted Apr 20, 2026 - 21:30 CDT
This incident affected: ShipStation and ShipStation Companion API (Companion API V1, Companion API V2).