Performance issues
Incident Report for ShipStation
Resolved
Thank you for your patience. Our engineering team has resolved the performance-related issues some of our merchants were experiencing! If you continue to see an issue please reach out to our support team.
Posted Mar 06, 2023 - 13:06 CST
Investigating
ShipStation is currently experiencing performance-related issues that may be causing slowness for merchants. We are aware of the impact this has on you, and we are working to identify the issue! We will provide frequent updates on our progress. Thank you for your continued patience, and check back soon!
Posted Mar 06, 2023 - 12:05 CST
This incident affected: ShipStation.