Performance Issues
Incident Report for ShipStation
Resolved
This incident has been resolved.
Posted Jan 19, 2024 - 10:14 CST
Investigating
ShipStation is currently experiencing performance-related issues that may be causing slowness for some merchants. We are aware of the impact this has on you, and we are working to identify the issue! We will provide updates as soon as they become available.
Posted Jan 19, 2024 - 09:45 CST
This incident affected: ShipStation.