Carrier Issues
Incident Report for ShipStation
Resolved
Thank you for your patience while our integrators worked to resolve your issues.
Please refresh your browser to reflect the changes made.

Thank you for your patience and understanding.
Posted Jun 06, 2024 - 13:20 CDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jun 06, 2024 - 12:10 CDT
Investigating
ShipStation is aware of the technical issues impacting UPS label creation. We are actively monitoring the status of these issues and will provide updates as they become available.
Thank you for your patience!
Posted Jun 06, 2024 - 10:50 CDT
This incident affected: ShipStation and Carriers (UPS).