Stamps.com increased response times.
Incident Report for ShipStation
Resolved
This incident has been resolved.
Posted 21 days ago. Sep 27, 2019 - 17:11 CDT
Monitoring
Stamps.com is believed to have resolved the issue. We are continuing to monitor the issue and will update this accordingly.

All systems and processes are returning to normal.
Posted 21 days ago. Sep 27, 2019 - 16:01 CDT
Update
Stamps.com is continuing to investigate the issue where users are unable to purchase labels, add funds, and other related actions.

Please check the following status pages for more information:

Stamps.com: https://status.stamps.com/
Endicia: https://status.endicia.com/
Posted 21 days ago. Sep 27, 2019 - 14:27 CDT
Update
We are continuing to monitor the increased response times and related issues when purchasing labels, adding funds, and similar actions through USPS carriers.

Postage providers affected are currently Stamps.com and Endicia. You can find their respective status pages here:

Stamps.com: https://status.stamps.com/
Endicia: https://status.endicia.com/
Posted 21 days ago. Sep 27, 2019 - 13:56 CDT
Update
We are continuing to monitor the increased response times when attempting to generate labels and perform other actions with Stamps.com.

https://status.stamps.com/
Posted 21 days ago. Sep 27, 2019 - 13:27 CDT
Investigating
We are currently seeing increased response times in regards to creating labels and getting rates through Stamps.com. We are monitoring the situation.

Stamps.com's status page can be found here: https://status.stamps.com/
Posted 21 days ago. Sep 27, 2019 - 10:30 CDT
This incident affected: Carrier Integrations.