ShipStation - Login Error
Incident Report for ShipStation
Resolved
This incident has been resolved.
Posted Apr 22, 2024 - 15:54 CDT
Investigating
ShipStation is aware of the technical issues impacting some merchant's ability to login to ShipStation. We are actively working to resolve this issue. We will provide updates as they become available to us. Thank you for your patience!
Posted Apr 22, 2024 - 14:37 CDT
This incident affected: ShipStation.