Incident relating to Stamps.com letter label creation
Incident Report for ShipStation
Resolved
This incident has been resolved.
Posted Sep 29, 2020 - 17:07 CDT
Update
We are continuing to investigate this issue.
Posted Sep 29, 2020 - 14:59 CDT
Investigating
We are currently investigating issues affecting Stamps zip code errors and USPS First Class Letter labels and will update our users as new information becomes available. Thank you for your patience.
Posted Sep 29, 2020 - 14:42 CDT
This incident affected: Carriers (Stamps.com) and Carrier Integrations.