ShipStation
Incident Report for ShipStation
Resolved
This incident has been resolved.
Posted Aug 28, 2024 - 13:02 CDT
Investigating
ShipStation is aware of the login issues impacting a portion of the ShipStation Platform. We are actively working to resolve this issue.
We will provide updates as they become available to us. Thank you for your patience!
Posted Aug 28, 2024 - 12:30 CDT
This incident affected: ShipStation.