Stamps.com label printing slowness
Incident Report for ShipStation
Resolved
This incident has been resolved.
Posted 14 days ago. Oct 04, 2019 - 12:19 CDT
Identified
Stamps.com has reported potential issues impacting label generation. We are monitoring this situation.

Status page can be found here: https://status.stamps.com/
Posted 14 days ago. Oct 04, 2019 - 10:58 CDT
This incident affected: Carrier Integrations.