Slowness on ShipStation
Incident Report for ShipStation
Resolved
This incident has been resolved.
Posted Feb 04, 2021 - 16:22 CST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Feb 04, 2021 - 14:54 CST
Identified
We are currently investigating an issue causing slow response for some ShipStation users. We apologize for the inconvenience and will provide updates as they are available. Thank you for your patience as we work to resolve this.
Posted Feb 04, 2021 - 14:19 CST
This incident affected: ShipStation.