SEKO LTL

Incident Report for ShipStation

Resolved

SEKO LTL is now available. If you continue to experience any issues with creating SEKO LTL labels, please reach out to our support teams. Thank you for your patience.
Posted Jun 22, 2022 - 14:44 CDT

Investigating

SEKO LTL is currently unavailable. Our team is assessing the issue. Thank you for your patience and understanding.
Posted Jun 21, 2022 - 15:56 CDT
This incident affected: Carrier Integrations.