UK - DPD Local

Incident Report for ShipStation

Resolved

This incident has been resolved by DPD Local.
Posted Sep 06, 2022 - 10:38 CDT

Investigating

We are currently seeing intermittent issues with DPD Local label generation in ShipStation and are investigating.
Posted Sep 06, 2022 - 10:23 CDT
This incident affected: Carrier Integrations.