Carrier Issues - Canada Post

Incident Report for ShipStation

Resolved

This incident has been resolved.
Posted Feb 27, 2026 - 15:44 CST

Investigating

ShipStation is currently experiencing performance issues due to an ongoing Canada Post outage. We are actively monitoring their status and its impact on our platform. We will provide updates as they become available. Thank you for your patience.
Posted Feb 27, 2026 - 10:35 CST
This incident affected: ShipStation and Carriers (Canada Post).