ShipStation Performance and Login Issues
Incident Report for ShipStation
Resolved
This incident has been resolved.
Posted Sep 05, 2023 - 14:21 CDT
Investigating
We are currently receiving reports of users being unable to log into ShipStation or seeing degraded performance within ShipStation. Our team is currently investigating this further and looking towards a solution. We appreciate your patience as we address these issues.
Posted Sep 05, 2023 - 11:41 CDT
This incident affected: ShipStation.