Amazon Buy Shipping
Incident Report for ShipStation
Resolved
This incident has been resolved. If you have any additional Amazon Buy Shipping concerns, please email us at support@shipstation.com.
Posted Oct 14, 2022 - 13:40 CDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Oct 14, 2022 - 11:33 CDT
Investigating
We are currently investigating reports of errors when utilizing Amazon Buy Shipping. This is the top priority for our team. We will post here with updates as we have them. Thank you for your patience!
Posted Oct 14, 2022 - 09:53 CDT