MyPost Business Service Impacts

Incident Report for ShipStation

Resolved

This incident has been resolved.
Posted Feb 13, 2025 - 17:37 CST

Update

We are continuing to investigate this issue.
Posted Feb 13, 2025 - 17:36 CST

Investigating

MyPost Business is currently facing some service disruptions, which may impact some ShipStation users.
We are actively working with them to mitigate the issues and will share more updates as soon as possible.
Posted Feb 12, 2025 - 17:46 CST
This incident affected: ShipStation.