ShipStation

Incident Report for ShipStation

Resolved

This incident has been resolved.
Posted Apr 22, 2025 - 08:26 CDT

Investigating

ShipStation is aware of the technical issues impacting postage payment processing on ShipStation. We are closely monitoring an issue with the payment processor, and we will provide updates as they become available to us. Thank you for your patience!
Posted Apr 21, 2025 - 15:25 CDT
This incident affected: ShipStation.