Slow speeds for some ShipStation services

Incident Report for ShipStation

Resolved

This incident has been resolved.
Posted Jun 08, 2020 - 13:55 CDT

Investigating

We are currently investigating the cause of slow speeds for some ShipStation services. We will provide an update once it's available. We apologize for the inconvenience.
Posted Jun 08, 2020 - 10:02 CDT
This incident affected: ShipStation.