ShipStation Account Slowness

Incident Report for ShipStation

Resolved

This incident has been resolved.
Posted Jan 24, 2022 - 10:46 CST

Investigating

Some users are experiencing slowness within their account causing loading and login issues. We are investigating this now and will follow up once we have any updates.
Posted Jan 24, 2022 - 09:45 CST
This incident affected: ShipStation.