UPS
Incident Report for ShipStation
Resolved
This incident has been resolved. Thank you for your patience.
Posted Mar 25, 2023 - 11:02 CDT
Investigating
We are aware of an issue merchants are having with creating UPS labels. This is being investigated by our teams. When we have additional information, we will follow up here.
Posted Mar 25, 2023 - 09:14 CDT
This incident affected: Carrier Integrations.