Canada Post 500 Errors
Incident Report for ShipStation
Resolved
This incident has been resolved.
Posted Aug 19, 2020 - 12:08 CDT
Investigating
We have received reports of Canada Post returning intermittent 500 errors and are investigating further.
Posted Aug 19, 2020 - 09:07 CDT
This incident affected: Carriers (Canada Post).