Loading/Navgiation Issues
Incident Report for ShipStation
Resolved
This incident has been resolved.
Posted Sep 19, 2022 - 13:19 CDT
Investigating
We are currently investigating isolated reports of merchants unable to navigate our platform. We will update as soon as we have additional information.
Posted Sep 19, 2022 - 10:39 CDT
This incident affected: ShipStation.