Issues with Stamps.com services
Incident Report for ShipStation
Resolved
This incident has been resolved.
Posted Apr 27, 2020 - 12:21 CDT
Investigating
We are currently investigating an issue affecting multiple users when attempting to utilize Stamps.com services. We will provide updates as they are available and apologize for any inconvenience.
Posted Apr 27, 2020 - 10:15 CDT
This incident affected: Carriers (Stamps.com).