Deutsche Post Cross Border
Incident Report for ShipStation
Resolved
This incident has been resolved.
Posted Mar 22, 2023 - 12:18 CDT
Identified
The issue has been identified and a fix is being implemented.
Posted Mar 22, 2023 - 11:13 CDT
Investigating
We are aware of an issue with merchants creating labels with Deutsche Post Cross Border. We're looking into this now and as soon as updates are available we will follow up here.
Posted Mar 22, 2023 - 10:06 CDT
This incident affected: Carrier Integrations.