Login Issues

Incident Report for ShipStation

Resolved

This incident has been resolved.
Posted Feb 18, 2026 - 14:36 CST

Investigating

ShipStation is investigating reports of login issues.
Posted Feb 18, 2026 - 13:18 CST
This incident affected: ShipStation.