Canada Post Service Issues
Incident Report for ShipStation
Resolved
Happy Friday! Canada Post has confirmed all services are now operational. Thank you for your patience and hope you have a great weekend
Posted Jun 02, 2023 - 07:57 CDT
Investigating
Canada Post is experiencing technical issues which are affecting the creation of shipments and printing labels.

They are currently working on a resolution and we can track this here: https://status.canadapost.ca/

We will provide updates as we receive them.
Posted Jun 01, 2023 - 13:52 CDT
This incident affected: Carriers (Canada Post).