High response times for some users
Incident Report for ShipStation
Resolved
This incident has been resolved.
Posted Oct 21, 2019 - 16:37 CDT
Monitoring
We identified the issue impacting response times for certain users. We are continuing to monitor the situation to confirm the situation has been resolved.
Posted Oct 21, 2019 - 16:09 CDT
Investigating
We are currently investigating reports of some users having high response times while navigating within the application and performing certain functions.
Posted Oct 21, 2019 - 13:30 CDT
This incident affected: ShipStation.