Degraded Performance for Stamps.com
Incident Report for ShipStation
Resolved
This incident has been resolved.
Posted Apr 15, 2020 - 15:58 CDT
Investigating
Stamps.com Engineers have identified an issue that may temporarily affect some of our customers' ability to print postage and shipping labels. Sorry for the inconvenience – we’ll have a solution for this soon!
Posted Apr 15, 2020 - 10:55 CDT
This incident affected: Carriers (Stamps.com).