Issues with Stamps label creation
Incident Report for ShipStation
Resolved
This incident has been resolved.
Posted Sep 18, 2020 - 14:55 CDT
Update
We are continuing to investigate this issue.
Posted Sep 18, 2020 - 13:39 CDT
Investigating
Stamps.com Engineers have identified an issue that may temporarily affect some of our customers' ability to print postage and shipping labels. Sorry for the inconvenience – we’ll have a solution for this soon!
Posted Sep 18, 2020 - 13:26 CDT
This incident affected: Carriers (Stamps.com).