Account Slowness
Incident Report for ShipStation
Resolved
This incident has been resolved.
Posted Dec 15, 2021 - 10:51 CST
Update
We are continuing to monitor this issue.
Posted Dec 15, 2021 - 09:51 CST
Identified
We have identified an issue with Amazon Web Services which is affecting general load times for some users. This may affect postage purchasing as well. We are investigating the issue with the proper parties now and hope to clear up any loading speeds as soon as possible.
Posted Dec 15, 2021 - 09:49 CST
This incident affected: ShipStation.