Performance issues on login to ShipStation

Incident Report for ShipStation

Resolved

This incident has been resolved.
Posted Apr 22, 2020 - 13:09 CDT

Investigating

We are currently investigating an issue that is affecting logins and UI response time. We apologize for the inconvenience and will provide updates as they are available.
Posted Apr 22, 2020 - 11:38 CDT
This incident affected: ShipStation.