Label Generation
Incident Report for ShipStation
Resolved
The source of this issue has been identified and resolved.
Posted Apr 26, 2023 - 19:06 CDT
Investigating
We are currently investigating an issue merchants have reported of label generation issues. Our development and engineering teams are already taking a look. As soon as we have updates or a resolution, we will let you know here.
Posted Apr 26, 2023 - 17:53 CDT
This incident affected: ShipStation.