ShipStation Login Issue

Incident Report for ShipStation

Resolved

Earlier today, ShipStation identified an issue affecting some merchants' ability to log in. Our engineers have confirmed this issue should now be resolved.
Posted Jun 03, 2026 - 17:16 CDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jun 03, 2026 - 16:32 CDT

Investigating

ShipStation identified an issue that affected some merchants' ability to log in. Our engineers are currently investigating the issue.
Posted Jun 03, 2026 - 12:54 CDT
This incident affected: ShipStation.