Stamps.com - Long Response times and label creation issues
Incident Report for ShipStation
Resolved
Stamps.com has resolved the issue affecting the various services. Operations have returned to normal.
Posted 17 days ago. Oct 01, 2019 - 16:04 CDT
Investigating
We are seeing an increase in response times for various Stamps.com functions such as getting rates and creating labels.

We will update as we have more information.
Posted 17 days ago. Oct 01, 2019 - 14:00 CDT
This incident affected: Carrier Integrations.